Aricie
The DNN Expert for your web project
Forum
HomeHomeModulesModulesHtmlMapMakerHtmlMapMakerMultiple Module Instances on One Page?Multiple Module Instances on One Page?
Previous
 
Next
New Post
5/12/2015 10:11 PM
 
We want to install 3 instances of map maker on one page.  Are there any issues we should be aware of?
 
New Post
5/13/2015 1:17 PM
 

Hello,

no there won't be any issues. You can use many instances of HtmlMapMaker on one page.

Please feel free to contact us if you have any questions.

Best Regards,

 
New Post
5/14/2015 5:51 PM
 

We have installed 2 instances on a page in 2 separate panes and configured 1 hotspot on each, for starters.  The second instance has the html content popping up on the map of the first instance.  I have a pdf of screen shots to illustrate, but not sure how to post or send to you.

It can be seen here: http://new.caryapartmenthomes.com/

An additional concern of our team is that the site is responsive and we want to be sure it performs well in that capacity.

Thank you, -Bob

 
New Post
5/14/2015 5:57 PM
 

FYI... we are also configuring a replacement map for another client where we had previously deployed the HTML Mapmaker module.  We were trying to configure it in a hidden module on the same page, but had difficulties with the same type of thing.  We just now moved it to another page where it is by itself and all is well.

There must be something we are missing, no?

 

Thank you, -Bob

 
New Post
5/18/2015 11:40 AM
 
Hello,
For the second instance who has the html content popping up on the map of the first instance, you can click on the hotspot and edit it.

You can configure both vertical and horizontal position through Hotspot Interactivity -> you choose the behaviour -> and you can modify position (there is also other properties like color, height, width.. that you can configure) -> then click update -> And finally save and return.

You can download our pdf documentation from this link : http://dotnetnuke.aricie.com/en/Download.aspx?DMXModule=455&EntryId=571&Command=Core_Download

For the responsivity of the module, the mouse over feature doesn't work on mobile. And also, positioning is absolute on the map.
So the module is not quite responsif, the subject may correspond to an evolution of HtmlMapMaker.

Best Regards,

 
New Post
5/28/2015 3:42 AM
 

We have successfully configured 3 instances on one page, however, only a few of the hotspots function properly. 

The first map on the page has 4 hotspots, all configured the same as far as I can tell, but only 2 of them show pop-up html.   They all have working hyperlinks.

The second map has 9 similarly configured hotspots, but only one is working.  Some do not show the hotspot shading upon hover. 

The third map has only one hotspot and it is working well.

Thank you, -Bob

 
New Post
5/28/2015 9:18 AM
 

Hello Bob,

thanks for following up on the module, we will get back to you asap.

Regards

 
New Post
5/28/2015 10:51 AM
 
Hello,
if you have similarly configured hotspots, you can check and change the interactivity behavior properties (Left and Top alignment) to display the html popups in the right position.

If you need a custom support, you can subscribe here : http://dotnetnuke.aricie.com/en/Support/Tickets.aspx .

Thank you.

Best Regards,

 

 

 
New Post
5/29/2015 2:36 AM
 

The pop-ups that work are positioned correctly and show as configured.  The ones that do not work are configured exactly the same as those that do.  This is with Firefox and Chrome.  We have 3 maps, stacked.  The 1st map functions correctly.  The second does not (although one hotspot does).  As a test I re-positioned it where the pop-up for the 1st map shows and it worked.  When I changed it back to same position as the one that works in Map #2, it does not work (no pop-up shows).

We are also seeing that the hotspots' shading is not showing correctly in Chrome, although they show as complete circles in Firefox.

If we need to purchase a support ticket I can do so.  I tried, but right now your PayPal account is down.

Thank you, -Bob

 
New Post
5/29/2015 10:34 AM
Accepted Answer 

Hello Rob and thanks for your feedback,

We'll check our paypal account configuration.

Regarding your problems, I noticed that the hotspots that don't work in the 2nd map differ from the one that works because the z-index attribute isn't set.

The one that works has "z-index:99999".

Could you try to add this to the other hotspots?

Regards




Stéphane TETARD
ARICIE - Board member of DotNetNuke France
 
Previous
 
Next
HomeHomeModulesModulesHtmlMapMakerHtmlMapMakerMultiple Module Instances on One Page?Multiple Module Instances on One Page?