Aricie
The DNN Expert for your web project
Forum
HomeHomeExpert ModulesExpert ModulesLuceneSearchLuceneSearchLuceneSearch - errors when using General Settings or Portal SettingsLuceneSearch - errors when using General Settings or Portal Settings
Previous
 
Next
New Post
5/25/2020 8:01 PM
 

Hello,

Environment is:
    DNN v9.4.1
    .NET 4.7

    Xcillion skin
    Aricie - Shared            2.0.6 (note NOT 2.0.0)
    Aricie - LuceneSearchResults    2.0.0
    I have removed HtmlAgilityPack.dll from bin folder

 

I can LuceneSearchResults module onto a page and it displays ok.
I can open General Settings and Portal Settings ok.

 

When I change tabs inside General Settings or Portal Settings, or if I try to Save, I get these and similar errors...

 

Property Editor dnn_ctr753_IndexerSettings_IdxS error on sub control dnn$ctr753$IndexerSettings$IdxS$contIndexingSettings$c0$IndexFolderMapPath$ec

 

Error System.Web.HttpException (0x80004005): Multiple controls with the same ID 'c0' were found. FindControl requires that controls have unique IDs. at System.Web.UI.Control.FillNamedControlsTable(Control namingContainer, ControlCollection controls) at System.Web.UI.Control.FindControl(String id, Int32 pathOffset) at Aricie.DNN.UI.WebControls.AriciePropertyEditorControl.FindControl(String strId, Int32 pathOffset)

 

An error has occurred. DotNetNuke.Services.Exceptions.ModuleLoadException: Multiple controls with the same ID 'c0' were found. FindControl requires that controls have unique IDs. ---> System.Web.HttpException: Multiple controls with the same ID 'c0' were found. FindControl requires that controls have unique IDs. at System.Web.UI.Control.FillNamedControlsTable(Control namingContainer, ControlCollection controls) at System.Web.UI.Control.FindControl(String id, Int32 pathOffset) at Aricie.DNN.UI.WebControls.AriciePropertyEditorControl.FindControl(String strId, Int32 pathOffset) --- End of inner exception stack trace ---

 

...
Is there a fix so the IDs are unique?

 

 

 
New Post
5/27/2020 8:42 AM
Accepted Answer 

Hi,

There are some breaking changes due to modifications to our Shared components.
We've planned to release a new version of LuceneSearch in some days. During that time, you could upgrade to the latest version of Aricie Shared which was released today. It might fix the error even if the UI has to be improved.

Regards




Stéphane TETARD
ARICIE - Board member of DotNetNuke France
 
New Post
7/29/2020 12:48 PM
 

Hello - sorry for being slow to reply. Aricie - Shared 2.0.8 resolved the "c0" issue - thank you.

Portal Settings -> Indexing -> "Search modules" was then blank.

However, I worked around this by removing HtmlAgilityPack.dll again.

 

 

 
Previous
 
Next
HomeHomeExpert ModulesExpert ModulesLuceneSearchLuceneSearchLuceneSearch - errors when using General Settings or Portal SettingsLuceneSearch - errors when using General Settings or Portal Settings